Quick Launch

Adnan's SharePoint Blog > Posts > How to install and configure SharePoint Server 2010 SP1 on the existing SP 2010 Farm
July 05
How to install and configure SharePoint Server 2010 SP1 on the existing SP 2010 Farm

This article assumes that SharePoint Server 2010 is already installed and configured. You can download the SharePoint Foundation 2010 and SharePoint Server 2010 SP1 from the following locations:

Upgrading the existing SharePoint Server 2010 farm to SharePoint Server 2010 SP1 consist of the following three steps:

 

Install SharePoint Foundation 2010 SP1

 

Follow the steps below to install SharePoint Foundation 2010 SP1:

  1. Log into the SharePoint application server by using the SharePoint Setup account and execute the sharepointfoundation2010sp1-kb2460058-x64-fullfile-en-us.exe file.
  2. SharePoint Foundation 2010 SP1 installation wizard will start.
  3. Tick Click here to accept the Microsoft Software License Terms and Click Continue.

     

  4. SharePoint Foundation 2010 SP1 installation is in progress…

     

     

  5. Once the installation of SharePoint Foundation 2010 SP1 is installed. The installer will request you to reboot the server. You should ignore this message and click NO.

     

     

  6. Now log into the remaining SharePoint Web/App servers in the farm and follow the above steps.

     

     

Follow the steps below to install SharePoint Server 2010 SP1:

 

  1. Log into the SharePoint application server by using the SharePoint Setup account and execute the officeserver2010sp1-kb2460045-x64-fullfile-en-us.exe file.
  2. SharePoint Server 2010 SP1 installation wizard will start.

     

     

  3. Tick Click here to accept the Microsoft Software License Terms and Click Continue.
  4. SharePoint Server 2010 SP1 installation is in progress…

     

     

  5. If SharePoint Server 2010 SP1 installation is failed for any reason as shown in the figure below then you need to re-execute the officeserver2010sp1-kb2460045-x64-fullfile-en-us.exe file.

     

     

  6. SharePoint Server 2010 SP1 installation is in progress…

     

  7. SharePoint Server 2010 SP1 installation is in progress…

     

     

  8. Now log into the remaining SharePoint Web/App servers in the farm and follow the above steps.

     

     

Follow the steps below to run the SharePoint configuration wizard:

 

  1. Log into the SharePoint application server by using the SharePoint Setup account and run the SharePoint configuration wizard.
  2. Click Next to proceed…

     

     

  3. You will be informed that IIS, SharePoint Timer and Administration services will reset during the configuration wizard. Click Yes and then Click Next to proceed…

     

     

  4. On the next screen, click Next to proceed…

     

     

  5. SharePoint configuration wizard will start upgrading the farm. Please be patient as it may take 15-20 minutes depending upon the connected content databases on the farm.

     

     

  6. Unfortunately the configuration wizard was failed in my case as shown in the figure below.

     

     

  7. Click Finish to complete the wizard and analyse the log file.
  8. In my case, configuration wizard was failed due to the following errors.

     

     

  9. Re-run the SharePoint configuration wizard. SharePoint configuration wizard is successful.

     

     

  10. Now verify that SharePoint 2010 farm is upgraded to SP1 level by checking the version number of Microsoft.Office.Server.dll, Microsoft.SharePoint.dll files and on the central administration web site. See screen shot below for details:

     

     

     

     

    I do hope that this article will help you to upgrade your existing SharePoint Server 2010 farm. Please share your experience in upgrading SharePoint Server 2010 farm to SP1 level.

     

 

 

Comments

Przemek

Hi Adnan,

Good article! Thanks for some fresh info about this.
I was worried about this  errors during installation, but finally everything looks good!.

Best wishes!
 on 06/07/2011 01:56

Thanks For Sharing

Good work Adnan

Regards

Faisal Masood
http://www.epmadmin.com
Softvative Inc
 on 06/07/2011 08:57

Re: How to install and configure SharePoint Server 2010 SP1 on the existing SP 2010 Farm

Hi Adnan,
I installed SP1 on a three server farm and all when okay on the two web servers but running Psconfigui.exe failed and gave me the error below, any ideas what could be the problem. I reran the config wizard and rebooted but still the same error, any ideas? 

Exception: System.TypeLoadException: Could not load type 'Microsoft.Office.Server.Search.WebControls.PopupControlExtender' from assembly 'Microsoft.Office.Server.Search, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' due to value type mismatch.
   at Microsoft.Office.Server.ApplicationRegistry.SharedService.ApplicationRegistryServiceInstance.get_TypeName()
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServiceInstanceInConfigDB(Boolean provisionTheServiceInstanceToo, String serviceInstanceRegistryKeyName, Object sharepointServiceObject)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServiceInstances(Boolean provisionTheServiceInstancesToo, String serviceRegistryKeyName, Object sharepointServiceObject)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServices(Boolean provisionTheServicesToo)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.Run()
   at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

Thanks,
Ian
 on 07/07/2011 05:12

restart when?

Hi Adnan,

I haven't tried it yet (still downloading stuff) but got a question on the steps.
when exactly I need to restart the server?
- after applying foundation sp1?
- after applying server sp1?
- after running sp config wizard?
 on 08/07/2011 00:43

It well

It well
 on 19/07/2011 07:17

Restart the servers

Hi,

You should restart the servers after running the SP Config Wizard.

Thanks
Adnan Ahmed
 on 20/07/2011 14:32

Didn't Do Foundation First

What to do if I did not install the Foundation SP at all.

I have 2010 Enterprise.
 on 21/07/2011 08:16

Didn't Do Foundation First

What to do if I did not install the Foundation SP at all.

I have 2010 Enterprise.
 on 21/07/2011 08:39

Arul

Hi
I have upgraded to SP1 in a staging farm. It was successully upgraded on the application server. But upgrade failed when I run the psconfig in one of the WFE server. When I try to re-run the psconfig it is not running the upgrade wizard rather it is connecting the repair wizard. please help me as how can I again proceed with the upgrade wizard. I'm stuck
 on 26/07/2011 02:47

Reply to Arul's query

Hi Arul,

Please provide steps that you have followed during the upgrade. If I understand you correctly, then you have installed SP1 on all servers in the farm and executed the psconfig on the APP server successfully, but when you tried to execute the psconfig on the web servers, it failed.

If my assumption is correct, then there is a slight mistake from your side. You have to execute the psconfig file on the APP server and stop at the step, where it prompts you to run the psconfig on remaning servers then you should execute the psconfig on the remaning servers and stop at the same step.
Then go back to app server and complete the wizard and follow the same on the remaning servers.

Let me know, if it does make sense.

Thanks
Adnan
Adnan AhmedNo presence information on 26/07/2011 13:55
1 - 10Next

Add Comment

Items on this list require content approval. Your submission will not appear in public views until approved by someone with proper rights. More information on content approval.

Title


Body *


Antispam


What is today's abbreviated value (DDD). For example, If today is tuesday then enter TUE (All upper case)

Attachments